WordPress Vulnerability Roundup: May 2020, Part 1

>>> Shared from Original Post iThemes

New WordPress plugin and theme vulnerabilities were disclosed during the first half of May, so we want to keep you aware. In this post, we cover recent WordPress plugin, theme and core vulnerabilities and what to do if you are running one of the vulnerable plugins or themes on your website.

New WordPress plugin and theme vulnerabilities were disclosed during the second half of April, so we want to keep you aware. In this post, we cover recent WordPress plugin, theme and core vulnerabilities and what to do if you are running one of the vulnerable plugins or themes on your website.

The WordPress Vulnerability Roundup is divided into four different categories:

  1. WordPress core
  2. WordPress plugins
  3. WordPress themes

Each vulnerability will have a threat rating of Low, Medium, High, or Critical.

WordPress Core Vulnerabilities

There have not been any WordPress vulnerabilities disclosed in the first half of May 2020.

WordPress Plugin Vulnerabilities

Several new WordPress plugin vulnerabilities have been discovered this month so far. Make sure to follow the suggested action below to update the plugin or completely uninstall it.

1. WP-Advanced-Search – High

WP-Advanced-Search versions below 3.3.7 have an Authenticated SQL Injection vulnerability.

The vulnerability is patched, and you should update to version 3.3.7.

2. LearnPress – High

LearnPress versions below 3.2.6.9 have multiple critical vulnerabilities.

The vulnerability is patched, and you should update to version 3.2.6.9.

3. Gmedia Photo Gallery – Medium

Gmedia Photo Gallery versions below 1.18.5 have Multiple Cross-Site Scripting vulnerabilities.

The vulnerability is patched, and you should update to version 1.18.5.

4. Ninja Forms – High

Ninja Forms versions below 3.4.24.2 have a CSRF to Stored XSS vulnerability.

The vulnerability is patched, and you should update to version 3.4.24.2.

5. WTI Like Post – Low

All versions of WTI Like Post have an Authenticated Stored Cross-Site Scripting vulnerability.

Remove the plugin. It is closed on WordPress.org pending review.

6. Advanced Order Export For WooCommerce – Low

Advanced Order Export For WooCommerce versions below 3.1.4 have an Authenticated Cross-Site Scripting vulnerability.

The vulnerability is patched, and you should update to version 3.1.4.

7. Elementor – Medium

Elementor versions below 2.9.8 have a SVG Sanitizer Bypass leading to Authenticated Stored XSS vulnerability,

The vulnerability is patched, and you should update to version 2.9.8.

8. Ultimate Addons for Elementor – High

Ultimate Addons for Elementor versions below 1.24.2 have Registration Bypass vulnerability.

The vulnerability is patched, and you should update to version 2.2.9.

9. Elementor Pro – High

Elementor Pro versions below 2.9.4 have an Authenticated Arbitrary File Upload vulnerability.

The vulnerability is patched, and you should update to version 2.9.4.

10. Chopslider – High

All versions of Chopslider have an Unauthenticated Blind SQL Injection vulnerability.

There is not a patch available and you should remove the plugin..

11. Page Builder by SiteOrigin – High

Page Builder by SiteOrigin versions below 2.10.16 have an CSRF to Reflected Cross-Site Scripting vulnerability.

The vulnerability is patched, and you should update to version 2.10.16.

12. WooCommerce – Low

WooCommerce Logo

WooCommerce versions below 4.1.0 have an Unescaped Metadata when Duplicating Products vulnerability.

The vulnerability is patched, and you should update to version 4.1.0.

WordPress Themes

1. Avada – High

Avada versions below 6.2.3 have Missing Permission Checks leading to Arbitrary Post Creation, Edition, Deletion and Stored XSS vulnerability.

The vulnerability is patched, and you should update to version 6.2.3.

How to Be Proactive About WordPress Theme & Plugin Vulnerabilities

Running outdated software is the number one reason WordPress sites are hacked. It is crucial to the security of your WordPress site that you have an update routine. You should be logging into your sites at least once a week to perform updates.

Automatic Updates Can Help

Automatic updates are a great choice for WordPress websites that don’t change very often. Lack of attention often leaves these sites neglected and vulnerable to attacks. Even with recommended security settings, running vulnerable software on your site can give an attacker an entry point into your site.

Using the iThemes Security Pro plugin’s Version Management feature, you can enable automatic WordPress updates to ensure you are getting the latest security patches. These settings help protect your site with options to automatically update to new versions or to increase user security when the site’s software is outdated.

Version Management Update Options
  • WordPress Updates –Automatically install the latest WordPress release.
  • Plugin Automatic Updates – Automatically install the latest plugin updates. This should be enabled unless you actively maintain this site on a daily basis and install the updates manually shortly after they are released.
  • Theme Automatic Updates – Automatically install the latest theme updates. This should be enabled unless your theme has file customizations.
  • Granular Control over Plugin and Theme updates – You may have plugins/themes that you’d like to either manually update, or delay the update until the release has had time to prove stable. You can choose Custom for the opportunity to assign each plugin or theme to either update immediately (Enable), not update automatically at all (Disable) or update with a delay of a specified amount of days (Delay).
Strengthening and Alerting to Critical Issues
  • Strengthen Site When Running Outdated Software – Automatically add extra protections to the site when an available update has not been installed for a month. The iThemes Security plugin will automatically enable stricter security when an update has not been installed for a month. First, it will force all users that do not have two-factor enabled to provide a login code sent to their email address before logging back in. Second, it will disable the WP File Editor (to block people from editing plugin or theme code), XML-RPC pingbacks, and block multiple authentication attempts per XML-RPC request (both of which will make XML-RPC stronger against attacks without having to turn it off completely).
  • Scan for Other Old WordPress Sites – This will checks for other outdated WordPress installs on your hosting account. A single outdated WordPress site with a vulnerability could allow attackers to compromise all the other sites on the same hosting account.
  • Send Email Notifications – For issues that require intervention, an email is sent to admin-level users.

Managing Multiple WP Sites? Update Plugins, Themes & Core At Once from the iThemes Sync Dashboard

iThemes Sync is our central dashboard to help you manage multiple WordPress sites. From the Sync dashboard, you can view available updates for all your sites and then update plugins, themes, and WordPress core with one click. You can also get daily email notifications when a new version update is available.

Try Sync FREE for 30 daysLearn more

A WordPress Security Plugin Can Help Secure Your Website

iThemes Security Pro, our WordPress security plugin, offers 30+ ways to secure and protect your website from common WordPress security vulnerabilities. With WordPress, two-factor authentication, brute force protection, strong password enforcement, and more, you can add an extra layer of security to your website.

Learn more about WordPress security with 10 key tips. Download the ebook now: A Guide to WordPress Security

The post WordPress Vulnerability Roundup: May 2020, Part 1 appeared first on iThemes.

>>> Read the Full Story at iThemes